UI: Endless looping with View 'Prereq View'

Description

I accidently clicked the Prereq view instead of Type/Name and I seem to have an endless loop of these messages -

12:32:24.702 SEVERE AWT-EventQueue-1 AbilityTreeViews:133 Found probable ability prereq cycle [Bard Magic Level,Bard Magic Level,Bard Magic Level,Bard Magic Level,Bard Magic Level,Bard Magic Level,Bard Magic Level,Bard Magic Level,Bard Magic Level,Bard Magic Level,Bard Magic Level,Bard Magic Level,Bard Magic Level,Bard Magic Level,Bard Magic Level,Bard Magic Level,Bard Magic Level,Bard Magic Level,Bard Magic Level,Bard Magic Level,Bard Magic Level] with prereqs [Initial Bard Magic Level,Bard Magic Level,Bard Magic Level]. Skipping.

Environment

PCGen v5.17.12-Dev Build 16453
Homebrew sets

Activity

Show:
Tom Parker
March 18, 2012, 10:05 AM

Insufficient information. How are the abilities granted to the PC in the data?

Andrew Maitland
March 18, 2012, 2:41 PM

In this case, those abilities Aren't granted to the PC, this is just changing the View.

However, if I was going to add them - Initial is added manually to Grant the ADD:SPELLCASTER to get the PC the correct spell caster. This in turns adds a 'Base Ability' for the Class to grant defines. Then to alter the actual level, you add another Ability Manually.

I'll see about putting a test case example together.

Tom Parker
March 18, 2012, 3:11 PM

Oh, it's in the view, then this is a UI issue

James Dempsey
March 18, 2012, 8:27 PM

I was not able to reproduce the issue with the data provided, but traced the potential issue and fixed that.

Andrew Maitland
March 18, 2012, 11:34 PM

Not seeing the looping. Thanks!

Fixed

Assignee

James Dempsey

Reporter

Andrew Maitland

Labels

None

Theme

None

Epic/Theme

None

Pending User Input

None

Components

Fix versions

Affects versions

Priority

Minor
Configure