Loading equipment from character, "loses" custom equipment.

Description

PCGen 6.0.0 RC1-dev
Pathfinder Core only

Make sure that tools - preferences - equipment "load from lst files only" is selected.

Create new character, human fighter, 10 stats, go to equipment page, buy/sell = cashless, create a heavy shield +2 and "buy it". Save the character.
Exit PCGen, load up Pathfinder Core, load the character just saved. shield + 2 is in the character, but is not purchasable.

Create a second character, human fighter, go to equipment page. You can not find the shield +2 to purchase, however if you try to create another one to purchase, the popup says that it already exists.

Items in the .pcg file exist and are added to the character, but do not show up as "purchasable".

Environment

None

Activity

Show:
Andrew Wilson
October 24, 2012, 1:53 AM
Edited

Hmm, this sounds like the bug I reported. I'd obviously forgotten that I'd closed down PCGen between making the custom item and subsequently not being able to give it to a second character. We closed that as we weren't able to reproduce the problem.

James Dempsey
October 24, 2012, 2:10 AM

The preference "Save Custom Equipment to customEquipment.lst" needs to be unchecked to reproduce this issue.

James Dempsey
October 24, 2012, 5:45 AM

The dataset's list of equipment is now refreshed after character load so that it picks up the custom equipment just loaded.

David Bender
October 24, 2012, 1:58 PM

Yup, thanks!!!!

Fixed

Assignee

James Dempsey

Reporter

David Bender

Labels

None

Theme

None

Epic/Theme

None

Pending User Input

None

Fix versions

Affects versions

Priority

Minor
Configure