PREText HTML formatting is out of order

Description

Requirements: TEXT: Spellcasting: Ability to spontaneously cast arcane spells. at least 1 and at least 1 spellcasting class that does not memorize spells and at least 1 Arcane spell of level 1

Environment

None

Activity

Show:
Tom Parker
April 6, 2014, 5:07 PM

Can more context be provided here? The problem is not in the text for PRESPELLCASTMEM so we need to know the original PRExxx (probably a PREMULT) in full to be able to diagnose what is happening here.

(I actually expect the issue is that it is should be:
Ability to spontaneously cast arcane spells. at least 1 <blah> and at least 1 spellcasting class th

...and the <blah> is being left out.

Andrew Maitland
July 1, 2014, 12:24 PM

I think it's entirely something with PRETEXT:

I just tested this. Here are two samples (CLASS LINE) viewing on the CLASS TAB

PRESPELLTYPE:1,Arcane=1
PRETEXT:Spellcasting: Ability to spontaneously cast arcane spells.
Displays:
Requirements: at least 1 Arcane spell of level 1 and TEXT: Spellcasting: Ability to spontaneously cast arcane spells. at least 1

PRETEXT:Spellcasting: Ability to spontaneously cast arcane spells.
PRESPELLTYPE:1,Arcane=1
Displays:
Requirements: TEXT: Spellcasting: Ability to spontaneously cast arcane spells. at least 1 and at least 1 Arcane spell of level 1

Note the 'at least 1' trailing after PRETEXT. Since it follows the PRETEXT I suspect it has the issue hidden in PRETEXT.

Cheers,

Tom Parker
July 1, 2014, 2:10 PM

Committed revision 24367.

Fixed

Assignee

Tom Parker

Reporter

Andrew Maitland

Labels

None

Theme

None

Epic/Theme

None

Pending User Input

None

Fix versions

Affects versions

Priority

Minor
Configure