Update Gradle build to work with gradle 2.2

Description

The gradle build currently only works with gradle v1.12. The script should be updated to be compatible with more recent versions.

Environment

None

Activity

Show:
James Dempsey
November 23, 2014, 7:28 AM
Edited

Gradle build now works with 2.2 and 1.12. It is also expected to work with 2.0 and 2.1, but this has not been verified.

I've put in full wrapper support so gradle is not needed to build pcgen, just use

or

The pcgen.sh file is now also created as part of the build.

Assignee

James Dempsey

Reporter

James Dempsey

Labels

None

Theme

None

Epic/Theme

None

Pending User Input

None

Components

Fix versions

Affects versions

Priority

Minor
Configure