Swashbuckler Weapon Training stacks with Keen

Description

I know these two features should never be put together, but I was trying to rebuild a pc's sheet who left a pathfinder server I'm helping to gm in. They were scheduled to duel another player and fled the server before it could happen. The owner of the server deleted the character by accident before the duel. so in rebuilding the character, I was doing my best to put in all the features that they had. I knew most of his equipment. I was not very familiar with swashbucklers before this. So I added the rapier with keen that he had to his sheet, and was surprised to see a crit range of 12-20. Only thing I can figure is that the improved critical from Swashbuckler Weapon Training is stacking with the Keen enchantment on the weapon. (and yes, now that we know he was cheating the system to make his character more effective, we're happy he's gone.)

https://www.d20pfsrd.com/magic-items/magic-weapons/magic-weapon-special-abilities/keen/
This ability doubles the threat range of a weapon. Only piercing or slashing melee weapons can be keen. If you roll this special ability randomly for an inappropriate weapon, reroll. This benefit doesn’t stack with any other effects that expand the threat range of a weapon (such as the keen edge spell or the Improved Critical feat).

http://www.d20pfsrd.com/classes/hybrid-classes/swashbuckler/
At 5th level, a swashbuckler gains a +1 bonus on attack and damage rolls with one-handed or light piercing melee weapons. While wielding such a weapon, she gains the benefit of the Improved Critical feat. These attack and damage bonuses increase by 1 for every 4 levels beyond 5th level (to a maximum of +4 at 17th level).

Environment

Windows 10 v6.08.00 RC6

Status

Assignee

Unassigned

Reporter

Daniel Frelick

Source Books

None

Data/LST Monkey

None

Theme

None

Theme

None

Dependent Data

None

Subtype

None

Contact Person

None

Email

None

Publisher Website

None

Permission Level

None

Epic/Theme

None

Pending User Input

No

Affects versions

Priority

Minor
Configure