PRECLASS:1,SPELLCASTER.Arcane=1 fails to work

Description

SPELLCASTER.Arcane fails to be recognized. Per Eric Smith's report:

This seems to be a problem with PRECLASS:1,SPELLCASTER.Arcane=1

I created a plain human wizard and found the same problem.

PCGen: 5.16.4
Data: PFCR
Class NG Human Wizard 1
Problem: Bought and equiped the White Robe of the Archmagi. NO bonuses received and no spell resistance granted.

The Debug Console shows the following when the White Robe is selected in the Gear Tab:

SEVERE plugin.pretokens.test.PreClassTester PreClass on equipment: Robe of the Archmagi (White) pre: at least 1 levels of SPELLCASTER.ARCANE
SEVERE plugin.pretokens.test.PreClassTester PreClass on equipment: Robe of the Archmagi (White) pre: at least 1 levels of SPELLCASTER.ARCANE

The Debug Console shows the following when the rode is purchased:

FINER pcgen.core.VariableProcessor getJepVariable: UniversalSchoolLVL
FINER pcgen.core.VariableProcessor getJepVariable: UniversalSchoolLVL
FINER pcgen.core.VariableProcessor getJepVariable: UniversalSchoolLVL
FINER pcgen.core.VariableProcessor getJepVariable: UniversalSchoolLVL
FINER pcgen.core.VariableProcessor getJepVariable: UniversalSchoolLVL
FINER pcgen.core.VariableProcessor getJepVariable: UniversalSchoolLVL
FINER pcgen.core.VariableProcessor getJepVariable: UniversalSchoolLVL
FINER pcgen.core.VariableProcessor getJepVariable: UniversalSchoolLVL
FINER pcgen.core.VariableProcessor getJepVariable: UniversalSchoolLVL
FINER pcgen.core.VariableProcessor getJepVariable: UniversalSchoolLVL

The Debug Console shows the following when the robe is equipped:

SEVERE plugin.pretokens.test.PreClassTester PreClass on equipment: Robe of the Archmagi (White) pre: at least 1 levels of SPELLCASTER.ARCANE
SEVERE plugin.pretokens.test.PreClassTester PreClass on equipment: Robe of the Archmagi (White) pre: at least 1 levels of SPELLCASTER.ARCANE
SEVERE plugin.pretokens.test.PreClassTester PreClass on equipment: Robe of the Archmagi (White) pre: at least 1 levels of SPELLCASTER.ARCANE
SEVERE plugin.pretokens.test.PreClassTester PreClass on equipment: Robe of the Archmagi (White) pre: at least 1 levels of SPELLCASTER.ARCANE
SEVERE plugin.pretokens.test.PreClassTester PreClass on equipment: Robe of the Archmagi (White) pre: at least 1 levels of SPELLCASTER.ARCANE
SEVERE plugin.pretokens.test.PreClassTester PreClass on equipment: Robe of the Archmagi (White) pre: at least 1 levels of SPELLCASTER.ARCANE
SEVERE plugin.pretokens.test.PreClassTester PreClass on equipment: Robe of the Archmagi (White) pre: at least 1 levels of SPELLCASTER.ARCANE
SEVERE plugin.pretokens.test.PreClassTester PreClass on equipment: Robe of the Archmagi (White) pre: at least 1 levels of SPELLCASTER.ARCANE
SEVERE plugin.pretokens.test.PreClassTester PreClass on equipment: Robe of the Archmagi (White) pre: at least 1 levels of SPELLCASTER.ARCANE
SEVERE plugin.pretokens.test.PreClassTester PreClass on equipment: Robe of the Archmagi (White) pre: at least 1 levels of SPELLCASTER.ARCANE
SEVERE plugin.pretokens.test.PreClassTester PreClass on equipment: Robe of the Archmagi (White) pre: at least 1 levels of SPELLCASTER.ARCANE
SEVERE plugin.pretokens.test.PreClassTester PreClass on equipment: Robe of the Archmagi (White) pre: at least 1 levels of SPELLCASTER.ARCANE

The console returns the following for SPELLCASTER.Arcane:

New1:SPELLCASTER.ARCANE = 0.0

I created a similar Evoker and got pretty much the same results (EvokerSchoolLVL comes up in addition to UniversalSchoolLVL) except that when the EvocationSchoolLVL is checked in the console it returns a value of 1.0.

Bottom Line: "Houston, we have a problem"

Maredudd

Environment

None

Activity

Show:
Henk Slaaf
January 17, 2012, 9:04 AM

A Sorcerer level 1 with the Robe of the Archmagi (White) gives a similar error message:

15:03:11.664 SEVERE AWT-EventQueue-1 PreClassTester:37 PreClass on equipment: Robe of the Archmagi (White) pre: at least 1 levels of SPELLCASTER.ARCANE

The LST files look fine.

Henk Slaaf
January 17, 2012, 12:17 PM

I see slightly different behaviour after all...

Sometimes my level 1 sorc gets a +4 bonus to saves, but also a -4 misc penalty to saves. These are both visible in the character sheet.

Douglas Limmer
January 18, 2012, 9:06 AM

The SPROP shows up for a 1st-level Wizard, but not for a 1st-level Cleric, when I try it. It uses the same PRECLASS tag as the AC and Save bonuses. (5.17.9, Pathfinder)

James Dempsey
October 15, 2012, 4:30 AM

Main fix was in r16607 on 25 Mar 12 but the error message has now been hidden also. Tested out the Robe of the Archmagi (White) and it worked correctly.

Fixed

Assignee

James Dempsey

Reporter

Andrew Maitland

Labels

None

Theme

None

Epic/Theme

None

Pending User Input

None

Fix versions

Affects versions

Priority

Minor
Configure